
Windows XP / 2000 Tips 

TOP 

Q. Where can I download Windows XP Service Pack 1 (SP1)? 

A. As of September 9, 2002, you can download XP SP1 from the URL below. The final build 
number for the service pack is 1106, and the service pack contains the new "Set Program Access 
and Defaults" feature. 
   http://www.microsoft.com/windowsxp/pro/downloads/servicepacks/sp1 

Q. When I use the Windows XP Service Pack 1 (SP1) or Windows 2000 SP3 "Set Program 
Access and Defaults" feature to remove access to a program, why doesn't the OS remove 
the actual program? 
A. Microsoft's agreement with the US Department of Justice (DOJ) states that the company has 
to remove visibility of its components, not the actual application code. The "Set Program Access 
and Defaults" feature doesn't remove the application executables and 
resources--doing so would have caused additional problems because many Microsoft 
applications interoperate with other parts of the Windows OS. 
      

Q. Why can't I start a Microsoft Office application after installing Windows 2000 Service 
Pack 3 (SP3)? 
A. Some users have received the following error message when they attempt to start an Office 
application after installing Win2K SP3: 
 
The Windows Installer Service could not be accessed. This can occur if you are running Windows 
in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel 
for assistance. 
 
The problem stems from a new version of Windows Installer (version 2) that ships with Win2K 
SP3. You might receive this error message for one of two reasons. Each reason has its own 
solution, which I detail below. 
   - Distributed COM (DCOM) default impersonation level is set to anonymous: To resolve the 
problem for this reason, perform the following steps 

1. Start the DCOM configuration utility by typing 
 
dcomcnfg 
 
at the command prompt. 
2. Select the Default Properties tab, then select Connect from the Default Authentication Level 
list. 
3. Select Identify from the Default Impersonation Level list, then click OK. 

4. Close the DCOM configuration utility. 
5. Start Windows Explorer and navigate to the system32 folder (e.g., c:\windows\system32). 
6. Right-click msisip.dll, select Rename from the context menu, change the filename to 
msisip.old, and click OK. 
7. Reinstall Win2K SP3. 
 
   - The SYSTEM account doesn't have permission to access a destination folder: To resolve the 
problem for this reason, perform the following steps: 
1. Start Windows Explorer, right-click the boot partition drive (typically the C drive, where the 



Windows folder resides), and select Properties from the context menu. 
2. Select the Security tab. 
3. Click Add. 
4. Select the System account, click Add, then click OK. 
5. Select the Full Control option under Allow, and click OK. 

Q. Why did my FTP password stop working on my Windows 2000 system after I installed 
the Win2K Security Rollup Package 1 (SRP1)? 
A. After you install the Win2K SRP1, Win2K considers leading white-space characters (i.e., 
spaces) in the FTP password to be valid characters and no longer removes them. As a result, if a 
stored password contains spaces, you must include the spaces when you enter the password. 
Likewise, if the password doesn't contain spaces, you must ensure that the password you type 
has no leading spaces. 

Q. Why does Windows 2000 prompt me to delete a folder when I delete a large file? 

A. When you attempt to delete a large file that typically goes into the Recycle Bin first, you'll 
receive the following error: 
 
Confirm Folder Delete 
The folder <filename> is too big for the Recycle Bin. Do you want to permanently delete it? 
 
You receive this error because the file is too large to fit in the Recycle Bin. To report this error, 
Win2K uses a shared error message that the OS also displays when you attempt to delete a 
folder that's too large to fit into the Recycle Bin. If you decide to permanently 
delete the file, Win2K will delete only the file--the OS won't delete a folder that has the same 
name. 

Q. Why do I receive Stop Error 0x0000007E in Windows XP when I add a new USB device? 

A. If the USB bandwidth consumption exceeds the 100-percent maximum that the USB 2.0 
update or XP Service Pack 1 (SP1) allows, you'll receive the error you mention. Specifically, if 
existing USB devices are already using the maximum bandwidth and you add another USB 
device (e.g., if you're viewing streamed audio or video through a USB device and plug in another 
USB device), you'll receive the following error 
message: 
 
STOP: 0x0000007E (0xC0000005, <address>, <address>, <address>) usbhub.sys 
 
To work around this problem, you can take one of the following actions: 
   - Connect your keyboard, mouse, or other USB device before you start streaming USB video or 
audio. 
   - If you've already started streaming USB video or audio, either stop or pause the stream, 
connect the keyboard, mouse, or other USB device, then start the stream again. 
   - If your computer has multiple USB host controllers, connect the keyboard, mouse, or other 
USB device to a USB host controller separate from the USB host controller that you're using to 
connect the USB video or audio device. Most computers sold in the past year have two or more 
USB host controllers. To verify this configuration, view the USB host controllers in Device 
Manager (go to Start, Settings, Control Panel, System, Hardware, and click Device Manager). 

Q. How do I restore or configure my own Microsoft Internet Explorer (IE) start and search 
pages? 



A. Some users have reported seeing adult content when they start IE or click Search in IE. Adult 
Web sites sometimes modify the values IE uses to tell the software which URLs to use for the 
default IE start and search pages. To resolve this problem, you can reset the registry values that 
control these settings by performing the following steps: 
   1. Start a registry editor (e.g., regedit.exe). 
   2. Navigate to the HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main registry 
subkey. 
   3. Review the settings for the Search Bar, Search Page, and Start  Page. 
   4. If any of the values indicate adult-based URLs, you can either delete the value, which causes 
IE to use the default setting, or modify these values to point to more-acceptable URLs. 
   5. Close the registry editor. 

  

Q. How can I configure multiple concurrent Microsoft Internet Explorer (IE) download 
sessions to one server? 

A. In accordance with Internet Engineering Task Force (IETF) Request for Comments (RFC) 
2068, IE 5.0 and later limit the number of concurrent downloads to one server. HTTP 1.0-based 
servers are limited to four sessions, and HTTP 1.1-based servers are limited to three sessions, 
one of which is queued. If your servers support high bandwidth and you want to establish more 
concurrent connections, perform the following steps: 
   1. Start a registry editor (e.g., regedit.exe). 
   2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet 
Settings registry subkey. 
   3. From the Edit menu, select New, DWORD Value. 
   4. Enter the name MaxConnectionsPer1_0Server for HTTP 1.0-based servers or enter the 
name MaxConnectionsPerServer for HTTP 1.1-based servers, then press Enter. 
   5. Double-click the new value, set it to the hexadecimal value for the number of connections 
you desire (e.g., "a" in hex for 10), then click OK. 
   6. Close the registry editor. 

Q. Why doesn't clipboard redirection work on my Windows 2000 Server Terminal Services 
client? 

A. Clipboard redirection lets you copy information from a Terminal Services session and paste it 
into the local console-based session. However, you might receive the following error message 
when you try to paste information from the clipboard: 
 
Cannot copy file: Cannot read from the source file or disk 
 
This error occurs when you upgrade the Terminal Services client to the Windows XP Remote 
Desktop client, then reinstall the Terminal Services client. To resolve this error, you need to 
reestablish the clipboard registry setting by performing the following steps: 
   1. Start a registry editor (e.g., regedit.exe). 
   2. Navigate to the HKEY_CURRENT_USER\Software\Microsoft\Terminal Server 
Client\Default\AddIns registry subkey. 
   3. From the Edit menu, select New, Key. 
   4. Enter the name RDPDR, then press Enter. 
   5. Close the registry editor. 
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Q. How can I set the default email program? 

A. The system registry maintains a list of email programs under the 
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail registry subkey. You can 
configure any one of these programs to be the default application for sending and reading email 
by performing the following steps: 
   1. Open the Microsoft Internet Explorer (IE) options dialog box (go to IE, click Tools, then select 
Internet Options). 
   2. Select the Programs tab. 
   3. Click on the E-mail drop-down box, select the preferred default application, then click OK. 
 
Be aware that changing this value also modifies the 
HKEY_CLASSES_ROOT\mailto\shell\open\command value to reflect the new client. Because the 
IE value modifies HKEY_CLASSES_ROOT, the default mail application you select is set on a 
machine basis, not on a per-user basis. As a result, you can't establish a different default mail 
application for multiple users on a single instance of Windows. 
 
If you log on as a regular user (i.e., non-Administrator) and change the default mail application, 
Windows will ignore your changes. If you log on as an Administrator and change the default mail 
application, your changes will affect all users on that system. 
 
You can create user-based shortcuts on the Start menu, Quick Launch bar, and desktop to make 
it easier for users to open a preferred email client. However, programs that use Messaging API 
(MAPI) calls, mailto: links, and "Send Page by E-Mail" in IE will still use the default mail 
application that you set for the machine. 

Q. Where can I get updated Windows XP boot disks? 

A. XP doesn't ship with boot disks, and you can't create these disks from the XP media. However, 
Microsoft provides downloads to create XP boot disks. As Microsoft continues to release service 
packs, the company will continue to update the downloadable boot disks, starting with new boot 
disks available for XP Service Pack 1 (SP1). You must download the correct set of boot disks for 
your version of XP (i.e., you can't use an XP Home Edition boot disk with an XP Professional 
Edition CD-ROM). XP Home SP1 boot disks are available at 
http://www.microsoft.com/downloads/release.asp?releaseid=42818 , and XP Pro SP1 boot disks 
are available at 
http://www.microsoft.com/downloads/release.asp?releaseid=42819 . 

Q. When I install Microsoft Office 2000, why doesn't Internet Explorer (IE) 5.0 and later 
recognize Word as an HTML editor? 
 
A. Because the Office installer doesn't register Word as an editor for the .htm file type, IE doesn't 
recognize Word as an HTML editor. Microsoft has resolved this problem in IE 5.5 and later. 
 
To use Word as an HTML editor on a machine running IE 5.0, you can either manually load an 
HTML file into Word and click Yes when the system prompts you to use Word as the default 
editor, or you can manually update your registry by performing the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.htm\OpenWithList registry subkey. 
3. From the Edit menu, select New, Key. 

4. Enter the name WINWORD.EXE, then press Enter. 
5. Close the registry editor. 
  



To confirm this setting, start IE, open the Tools menu, and select Internet Options. Select the 
Programs tab and click the "HTML editor" drop-down list to ensure that Microsoft Word is an 
option. 
 
Q. How can I prevent Windows XP from maintaining a thumbnail cache? 
 
A. XP keeps a thumbnail cache of images on your machine. However, if these images change 
frequently, the OS might not always update the cache file, and thus display the wrong thumbnail. 
For the same reason, you might simply want to prevent the OS from creating the cache file (i.e., 
thumbs.db) altogether. To stop the OS from maintaining the 
cache file, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced 
registry subkey. 
3. Double-click the DisableThumbnailCache value or create this 
value of type DWORD if it doesn't exist. 
4. Set the value to 1, then click OK. 
5. Close the registry editor. 
6. Log off and log on for the change to take effect. 

 
Q. How can I configure the grace period that Windows uses for password-protected screen 
savers? 
 
A. By default, when you activate a password-protected screen saver, Windows provides a brief 
grace period during which keyboard and mouse activity will stop the screen saver and let you 
access the system without having to enter the password. To modify this grace period, perform the 
following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Winlogon registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name ScreenSaverGracePeriod, then press Enter. 
5. Double-click the new value, set the "Value data" to the number of seconds (from 0 to 
2,147,483) that you want to use for the grace period, set the Base type to "decimal", then click 
OK. 
6. Restart the machine for the change to take effect. 
 
Q. Why do I receive an error when I try to run the Internet Connection Wizard (ICW) on my 
non-networked computer? 
 
A. The error, 
 
"You are restricted from running the Internet Connection Wizard. Contact your Network 
Administrator for more information." 
 
is the result of a policy setting that you can configure using the Internet Explorer Administration 
Kit (IEAK). To remove the policy setting, perform the following steps: 

1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel registry 
subkey. 



3. Delete the Connwiz Admin Lock value. 
4. Exit the registry editor. 
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Q. Why can't I add or remove programs after I install Microsoft Internet Explorer (IE) 6.0 or 
IE 5.5 on Windows 2000? 
 
A. A bug in the IE 6.0 and IE 5.5 installation procedure prevents you from adding or removing 
new programs. To resolve this problem, you can try to reinstall IE. If reinstalling the Web browser 
doesn't work, perform the following steps: 
1. Reboot you machine. 
2. During startup, press F8 to start the computer in Safe mode with Networking. 
3. Use the Local Administrator account to log on (the Windows Update dialog box will appear and 
state that Windows is updating the following items: browsing services, Internet tools, and system 
services). 
4. Run the Control Panel Add/Remove Programs applet and ensure that you can see the installed 
programs listed correctly as you'd expect. 
5. Reboot the machine. 

Q. Why can't I use the CD command to change directories to a Universal Naming 
Convention (UNC) path in a command window? 
 
A. When you attempt to use the CD command to change directories to a UNC path, you receive 
the following error: 
 
"CMD does not support UNC paths as current directories." 
 
Although you can map a drive, use the CD command to change to the new drive, then disconnect 
after you're done working in the UNC location, this approach is cumbersome. A better approach 
is to use the Pushd command. For example, you can enter 
 
pushd \\titcanic\data 
 
The Pushd command automatically maps a drive and navigates to it. If you run the Net Use 
command after you run Pushd, you'll see a new drive mapping. After you're done working in the 
UNC location, use the Popd command to navigate back to your original network location before 
you ran Pushd. 

  

Q. Why do I receive an ngina.dll error when I use Windows XP's Remote Desktop feature to 
attempt to connect to a remote machine running Lotus Notes 5? 
 
A. Lotus Notes 5 includes a Client Single User Logon option that lets a user access Lotus Notes 
without entering a password. Systems that use this feature run the Lotus Notes version of 
ngina.dll. When you attempt to connect to such a system, an incompatibility with the XP Remote 
Desktop version of ngina.dll results in the following error: 
 
"You cannot initiate a Remote Desktop Connection because the Windows logon software on the 
remote computer has been replaced by incompatible software ngina.dll. 
 
To correct this problem, please have the administrator of the remote computer contact the 
program vendor for a version that is compatible with Windows." 
 



Lotus Notes always installs its own version of ngina.dll but only enables this file when you use the 
Client Single User Logon option. This option is set in the registry at the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Winlogon\GinaDLL registry subkey. 
 
To resolve the error, uninstall then reinstall Lotus Notes 5 without enabling the Client Single User 
Logon option. Although you might be tempted to simply delete the GinaDLL registry value, this 
action will corrupt the Lotus Notes single user logon feature. 
 
Q. How can I disable Windows 2000 Server's Web Printing feature? 
 
A. By default, Win2K servers display printers on a Web page at http://<server>/printers . To 
disable this Web-based display (and thus the Web Printing), perform the following steps: 
   1. Start a registry editor (e.g., regedit.exe). 
   2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Printers 
registry subkey. 
   3. From the Edit menu, select New, DWORD Value. 
   4. Enter the name DisableWebPrinting, then press Enter. 
   5. Double-click the new value, set it to 1, then click OK. 
   6. Exit the registry editor. 
   7. Restart the server for the change to take effect. 
 
Q. Why are the network shares still active in Windows 2000 after I unbind the "Client for 
Microsoft Networks" service? 
 
A. Unbinding the "Client for Microsoft Networks" service disables the remote procedure call 
(RPC) service but doesn't disable the Lanman Server service, which serves shares on your 
computer. To stop serving shares, either delete the shares or unbind the "File and Printer Sharing 
for Microsoft Networks" service. 
 
To unbind the "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft 
Networks" services in Win2K, perform the following steps: 
   1. Start the Control Panel Network applet (go to Start, Settings, Control Panel, Network and 
Dial-up Connections; right-click Local Area Connection; and select Properties from the context 
menu). 
   2. From the General tab, clear the "Client for Microsoft Networks" check box and clear the "File 
and Printer Sharing for Microsoft Networks" check box. (To bind these services, select both check 
boxes.} 
   3. Click OK. 
 
Q. How can I prevent regedit from remembering the last registry key location I accessed 
under Windows XP? 
 
A. In a previous FAQ 

(http://www.windows2000faq.com/articles/index.cfm?articleid=14753 ), I explained how to write a 
script to automatically reset the last key location every time you log on to the OS. Another option 
for clearing the last registry key accessed is to use registry permissions to disable Write access to 
the key. To do so, perform the following steps: 
   1. Start the registry editor. 
   2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit registry 
subkey. 
   3. Select LastKey. 
   4. If you're working in XP, open the Edit menu and select Permissions; if you're working in 



Windows 2000, open the Security menu and select Permissions. 
   5. Remove Full Control access and grant Read-only access. 
   6. Click OK. 
 
You'll need to repeat this process for all users who don't want regedit to remember the last key 
location they accessed. 
 
Q. How can I configure the automatic update feature in Windows Media Player (WMP) 7 
and later? 
 
A. You can configure WMP to automatically check for updates once a day, once a week, or once 
a month. To configure this setting, open the Tools menu, click Options, then select the Player tab. 
To turn off the automatic update feature, perform the following steps: 
   1. Start a registry editor (e.g., regedit.exe). 
   2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsMediaPlayer 
registry subkey, or create this subkey if it doesn't exist. 
   3. From the Edit menu, select New, DWORD Value. 
   4. Enter the name DisableAutoUpdate, then press Enter. 
   5. Double-click the new value, set it to 1, then click OK. 
   6. Close the registry editor. 
   7. Restart WMP for the change to take effect. 

Back to Top 
 
Q. How can I configure Notepad to remember Page Setup settings? 
 
A. Notepad lets you configure document-specific settings (e.g., margins, page orientation, header 
and footer), which you access by selecting the Page Setup option from the File menu. However, 
Notepad reverts to using default Page Setup settings every time you restart the program. To 
configure Notepad to remember your Page Setup settings, perform the following steps: 
   1. Start a registry editor (e.g., regedit.exe). 
   2. Navigate to the HKEY_CURRENT_USER\Software\Microsoft\Notepad registry subkey. 
   3. From the Edit menu, select New, DWORD Value. 
   4. Enter the name fSavePageSettings, then press Enter. 
   5. Double-click the new value, set it to 1, then click OK. 
   6. Log off and log on for the change to take effect. 

  

Q. How can I stop Windows 2000 from using an encrypted format when I 
copy encrypted files to a server? 
 
A. By default, when you copy locally encrypted files to a server, Win2K retains the encryption 
format. However, you might not want server-based files to be encrypted. For example, a laptop 
user might want to encrypt files locally for security reasons but want the server-based files to be 
unencrypted so that other users can view the files. 
 
To stop Win2K from copying files to a server in an encrypted format, perform the following steps 
on the destination server: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem 
registry subkey. 
3. Select the NtfsEncryptionService value, then select Edit, Delete 



from the menu bar. 
4. Close the registry editor. 
5. Reboot the server for the change to take effect. 
 
After you make this change, you'll no longer be able to encrypt files on the server and Win2K will 
decrypt any encrypted files that users copy to the server. 
 
Q. How can I upgrade an IEEE 1394 (FireWire)-connected disk to a 
dynamic disk under Windows XP? 
 
A. By default, XP doesn't let you convert a FireWire-connected disk to a dynamic disk. However, 
you can make a simple registry change to accomplish such an upgrade. To convert a FireWire-
connected disk to a dynamic disk, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\dmadmin\Parameters 
registry subkey. 
3. Double-click EnableDynamicConversionFor1394, set this value to 
1, then click OK. 
4. Close the registry editor. 
5. Reboot the machine for the change to take effect. 
 

Q. How can I view and clear my DNS cache content? 
 
A. When a Windows XP or Windows 2000 machine queries a DNS server, the response is either 
positive (a match was found) or negative (no match was found). The OS stores these results in a 
local DNS cache so that local clients don't repeatedly query the DNS server for the same 
address. These DNS cache entries are known as DNS Resource Records (RR), and the DNS 
resolver always checks the local cache before it 
queries the DNS server. 
 
To view the current DNS resolver cache content and the entries preloaded from the Hosts file, go 
to the command prompt and type 
 
C:\> ipconfig /displaydns 
 
Each entry shows the remaining Time to Live (TTL) in seconds. To clear the cache, go to the 
command prompt and type 
 
C:\> ipconfig /flushdns 
 
Flushing the DNS cache clears all entries and reloads the entries from 
the Hosts file. 
 
Q. How can I configure the amount of time the DNS cache stores 
positive and negative responses? 
 
A. By default, Windows stores positive responses in the DNS cache for 86,400 seconds (i.e., 24 
hours) and stores negative responses for 300 seconds (i.e., 5 minutes). To modify these values, 
perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters 
registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name MaxCacheEntryTtlLimit to change the positive cache period or the name 



NegativeCacheTime to change the negative cache period, then press Enter. 
5. Double-click the new value, set it to the desired number of seconds (e.g., if you entered the 
name NegativeCacheTime, you could set the value to 0 to stop Windows from caching any 
negative responses), then click OK. 
6. Repeat Step 5 for the other value, if required. 
7. Close the registry editor. 
8. Reboot the computer for the changes to take effect. 
 
Q. What's DNS round robin and subnet prioritization? 
 
A. The most common type of DNS record is a Resource Record (RR) type A, which is a record 
that provides the IP address for a specified host name. In certain instances, a host name might 
resolve to multiple IP addresses, each with its own A record. For example, if three servers host 
the http://www.savilltech.com Web site, the DNS server might contain the following three address 
records: 
 
www.savilltech.com.IN A200.200.10.1 
www.savilltech.com.IN A200.200.11.1 
www.savilltech.com.IN A200.200.12.1 
 
When a client queries a DNS server for this host, the server returns all three address records. To 
avoid sending every client to the first address record (and, hence, the first host) every time, the 
DNS server uses a round-robin algorithm, which Internet Engineering Task Force (IETF) Request 
for Comments (RFC) 1794 describes. With each request, the algorithm rotates the order in which 
the DNS server returns the address records to more evenly distribute the load across all hosts. 
For example, the first time a client queries the DNS server, the server might return 
 
200.200.10.1 200.200.11.1 200.200.12.1 
 
to the client. The second time, the DNS server would return 
 
200.200.11.1 200.200.12.1 200.200.10.1 
 
The third time, the DNS server would return 
 
200.200.12.1 200.200.10.1 200.200.11.1 
 
and so on. 
 
If the client making the request connects directly to a subnet that contains one of the returned 
host addresses, having the client communicate directly with the host that corresponds to that 
address would reduce response time and network traffic. Subnet prioritization is a feature that 
recognizes when a host is on the same subnet as the client and returns the local host's address 
first. (Microsoft introduced subnet prioritization in Windows NT 4.0 Service Pack 4--SP4--and 
later.) When a client uses subnet prioritization, the client resolver receives address record results 
and sorts them according to the order of direct subnet connectivity. 
 
So, for example, if a client has address 200.200.11.5 (which is part of subnet 200.200.11) and the 
DNS server would typically return address record results of 
 
200.200.10.1 200.200.11.1 200.200.12.1 
 
the local DNS resolver will use subnet prioritization to re-sort the results according to the local 
subnet priority and return results of 
 
200.200.11.1 200.200.10.1 200.200.12.1 



 
to the client. Consequently, the local DNS resolver's subnet prioritization takes priority over the 
DNS server round robin when a resolved address is on the local subnet. Although this approach 
reduces network traffic, it doesn't balance the load across hosts. 
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Q. How can I enable or disable subnet prioritization on a client 
machine? 
 
A. In the FAQ titled "What's DNS round robin and subnet prioritization?," I explained how subnet 
prioritization cuts down on network traffic but defeats the load-balancing effect of the DNS server 
round robin. If balancing the load across the hosts is more important than traffic management, 
you might want to disable subnet prioritization. To do so, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe) on each client machine. 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters 
registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name PrioritizeRecordData, then press Enter. 
5. Double-click the new value, set it to 0, then click OK. 
6. Close the registry editor. 
7. Reboot the machine for the change to take effect. 
 
To reenable subnet prioritization, either delete the PrioritizeRecordData registry value or set this 
value to 1. 
 
Q. How can I enable or disable subnet prioritization on the DNS 
server? 
 
A. The DNS server can check the IP address of a client that's requesting name resolution and 
sort the results the DNS server returns to the client according to the proximity of the host address 
to the querying IP address. To enable or disable this functionality, perform the following steps on 
the DNS server: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters\ 
registry subkey. 
3. Double-click LocalNetPriority, or create this value of type DWORD if it doesn't exist. 
4. Set the value to 1 to enable subnet prioritization or 0 to disable subnet prioritization, then click 
OK. 
5. Restart the server for the change to take effect. 
 
Under Windows 2000 and later, you can also use the DNS Management Console to set this 
functionality. To use this tool to change the setting, go to Start, Programs, Administrative Tools, 
then click DNS Management Console; right-click the server and select Properties; 
select the Advanced tab; then clear or select the "Enable Netmask Ordering" check box. You can 
also control the round-robin functionality by opening the DNS Management Console Advanced 
tab and clearing or selecting "Enable round robin". The following list describes the expected 
functionality, depending on the values you set: - Subnet prioritization disabled, round robin 
disabled--The DNS server returns records in the order they were added to the database. - Subnet 
prioritization enabled, round robin disabled--The DNS server returns records in the order of the 
local subnet priority. - Subnet prioritization disabled, round robin enabled--The DNS server 
returns records in rotation according to the order they were added to the database. - Subnet 
prioritization enabled, round robin enabled--The DNS server returns records in rotation according 
to the local net priority. 



 
Q. How can I ensure that the DNS resolver uses only results from 
queried DNS servers? 
 
A. By default, if a client requests name resolution, the client will accept any response with the 
correct query ID, regardless of where the response is from. This behavior could lead to security 
problems if a rogue process that deliberately returns incorrect information exists on a system. To 
force the DNS resolver to match the source IP address of the response with the DNS servers that 
the DNS resolver queried, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe) on each client machine. 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters 
registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name QueryIpMatching, then press Enter. 
5. Double-click the new value, set it to 1, then click OK. 
6. Close the registry editor. 
7. Reboot the machine for the change to take effect. 
 
Q. How can I stop Windows XP from displaying the time in the 
notification area? 
 
A. To stop XP from displaying the time on the desktop in the notification area, perform the 
following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 
registry subkey to hide the time for the current user or to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer 
registry subkey to hide the time for all users. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name HideClock, then press Enter. 
5. Double-click the new value, set it to 1, then click OK. 
6. Close the registry editor. 
7. Log off or restart the machine for the change to take effect. 

Q. What are the system and boot partitions? 
 
A. Windows uses a system partition and a boot partition during start-up. The system partition 
contains core files (i.e., Windows NT Loader--NTLDR--boot.ini, ntdetect.com) that the OS 
requires for the first stage of system start-up. The system partition is always 
partition 0 (active), which is typically the C drive. The boot partition contains the OS files, which 
are typically located in the \winnt folder, the \windows folder, and the \system32 subfolder. On a 
dynamic disk, the system and boot partitions are known as the system and boot volumes. 
 
The system and boot partitions or volumes can be the same partition, but they don't have to be. 
There can be only one system partition. However, you can have multiple boot partitions in a 
multiboot environment--one boot partition for each OS you install on the system. 
 
Q. When I add a static IP route, what value do I use for the interface? 
 
A. The Windows IP subsystem uses IP configuration information (e.g., subnets, gateways) to 
automatically create a routing table that dictates how the OS will send IP packets to other host 
systems. To view the routing table on your system, open a command prompt and type 
 
route print 



 
You'll see a routing table similar to the following sample table: 
 
================================================================= 
Interface List 
0x1 ........................... MS TCP Loopback interface 
0x2 ...00 10 a4 8b 4b 8e ...... Intel(R) PRO/100+ MiniPCI - Packet 
Scheduler Miniport 
0x4 ...44 45 53 54 42 00 ...... Nortel IPSECSHM Adapter - Packet 
Scheduler Miniport 
0x20003 ...00 04 5a 0c 96 db ...... Instant Wireless - Network PC CARD 
#2 - Packet Scheduler Miniport 
================================================================== 
Active Routes: 
Network Destination Netmask Gateway Interface Metric 
0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.100 30 
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1 
192.168.1.0 255.255.255.0 192.168.1.100 192.168.1.100 30 
192.168.1.100 255.255.255.255 127.0.0.1 127.0.0.1 30 
192.168.1.255 255.255.255.255 192.168.1.100 192.168.1.100 30 
224.0.0.0 240.0.0.0 192.168.1.100 192.168.1.100 30 
255.255.255.255 255.255.255.255 192.168.1.100 2 1 
255.255.255.255 255.255.255.255 192.168.1.100 192.168.1.100 1 
255.255.255.255 255.255.255.255 192.168.1.100 4 1 
Default Gateway: 192.168.1.1 
================================================================== 
Persistent Routes: 
None 
Occasionally, the automatically generated routing table will be inaccurate and you might want to 
use the Route Add command to force a particular route for some IP traffic. You can obtain 
information about this command by typing 
 
route /? 
 
at the command prompt, but the basic syntax is 
 
route [-p] add <destination> mask <subnet mask> <gateway> metric <lowest number wins> if 
<interface> 
 
For example, 
 
route -p add 0.0.0.0 mask 0.0.0.0 192.168.1.1 metric 1 if 0x20003 
 
This sample command uses the -p option to add a persistent route (i.e., 0.0.0.0) that will still be in 
place, even after a reboot, to all destinations. This persistent route will use the 192.168.1.1 
gateway with the highest priority (i.e., metric 1) on interface 0x20003 (i.e., wireless network). The 
last piece of this information is the interface. Determining which value to use for the interface can 
sometimes be confusing. Basically, you use the Interface List value that appears in the first part 
of the routing table. In the sample 
table above, the valid values are 0x1, 0x2, 0x4, and 0x20003. Although this information is easy to 
obtain, the first part of the routing table often scrolls off screen, leaving users unsure of what 
value to use. 

Back To Top 
 
Q. How can I set the state of the Function Lock key on my new 



Microsoft keyboard? 
 
A. The new Microsoft keyboards assign actions such as Save or Open to the function keys. To 
enable the default functionality of a function key without performing the action that Microsoft has 
assigned to the key, you must press the Function Lock key before you press the function key. 
Unfortunately, the new keyboards don't contain a programmatic way to set the state of the 
Function Lock key. Therefore, you can't configure the keyboard to enable the Function Lock key 
by default; you must press Function Lock every time you start your machine. 
 
Q. How can I use Windows 2000's Disk Cleanup Wizard? 
 
A. Win2K introduced the Disk Cleanup Wizard, which checks a specified volume and estimates 
the amount of disk space you might be able to recover and use. The wizard can identify space 
savings in several areas, including 
- program files that you've downloaded and installed 
- temporary Internet files 
- temporary files 
- temporary offline files (Win2K only) 
- offline files (Win2K only) 
- Recycle Bin content 
- offline Web pages (Windows XP only) 
- setup log files (XP only) 
- compressed files that you haven't accessed recently 
- catalog files for the content indexer that the OS used during a previous indexing operation 
 
To run the Disk Cleanup Wizard, perform the following steps: 
1. Start Disk Cleanup (go to Start, Programs, Accessories, System Tools, and click Disk 
Cleanup). 
2. Select the name from the displayed list of the disk volume that you want to check for available 
free space, then click OK.(The wizard displays the status as it checks the various elements--the 
wizard spends most of its time checking for files that it can compress. 
3. After the analysis is complete, the wizard presents a summary with options you can select for 
freeing up space. Select the options you want to use and clear those options you don't want to 
use. 
4. Under the More Options tab, you can take additional steps to free disk space, such as 
removing installed programs and Windows components as well as deleting all but the most recent 
system restore point. After you've made your selections, click OK. 
5. Click Yes to the action confirmation. 
 
Depending on the volume you select, the wizard will display different elements. For example, a 
nonboot partition or volume will exhibit options related to the Recycle Bin, compressed files that 
you haven't accessed recently, and the content-indexer intermediary catalog files. After you click 
Yes on the action confirmation, a dialog box will appear that displays the progress of the disk 
cleanup. The wizard will exit after it finishes the cleanup. 
 
Q. How can I start Windows 2000's Disk Cleanup Wizard from the command line? 
 
A. To start the GUI version of the Disk Cleanup Wizard, open a command prompt and type 
 
cleanmgr 
 
You can also create a configuration set to run the wizard without any user interaction at a future 
time. To create a configuration set, open a command prompt and type 
 
cleanmgr [/d<drive>:] /sageset: <numeric between 0 and 65535> 
 



The /d option specifies the drive you want the wizard to clean up. If you don't specify a drive, the 
wizard will act on all volumes. If the volume you specify isn't the system partition or volume, the 
wizard will check for space that it can recover by performing actions only on the Recycle Bin and 
content-indexer intermediary catalog files. The /sageset argument dictates which parameters 
appear in the dialog box in which you select the cleanup options that you want to perform. The 
different numeric values associated with the /sageset argument correspond to different sets of 
parameters. Make your selections in this dialog box, then click OK. 
 
Windows will save your configuration in the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\VolumeCac
hes registry subkey. To run the Disk Cleanup Wizard without user 
interaction, use the command 
 
cleanmgr /sagerun: <numeric from 0 to 65535 defined by /sageset> 
 
The only visible indicator that the wizard is running will be a dialog box that shows the disk-
cleanup progress and gives the user the opportunity to cancel the task. However, the user can 
ignore this dialog box and the wizard will perform the cleanup without requiring user confirmation. 
You can define up to 65536 sets of parameters; however, I don't think that many combinations 
actually exist. 

Q. How can I configure the number of customized folders that Windows XP remembers? 
 
A. XP lets you customize different appearance settings for different folders (e.g., some folders 
might display details while others display thumbnail images). XP remembers these settings for as 
many as 400 customized folders and stores this information under the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags registry 
subkey. However, you can increase or decrease the number of customized folders that XP 
remembers by performing the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name BagMRU Size, then press Enter. 
5. Double-click the new value, set it to the number of folders that you want XP to remember, then 
click OK. 
6. Repeat Steps 3 through 5 under the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam registry subkey as well. 
7. Close the registry editor, then reboot the system for the change to take effect. 
 
Q. How can I clear my customized folder settings in Windows XP? 
 
A. To clear any customized folder settings, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell registry subkey. 
3. Delete the Bags and BagMRU subkeys. 
4. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam registry subkey. 
5. Delete the Bags and BagMRU subkeys. 
6. Close the registry editor, then reboot the machine for the changes to take effect. 
 
Q. Why does text appear in the bottom left of my screen after I install Windows Media 
Player (WMP) 9 beta on Windows 2000? 
 
A. In the beta-test version of Win2K and later Windows versions, text appeared on screen to 



indicate that the user was running a beta version. This text typically stated "Microsoft Windows 
2000 Professional, For Testpurpose only, Build 2195." To stop the text from appearing, you 
needed to set the HKEY_CURRENT_USER\Control 
Panel\Desktop\PaintDesktopVersion registry value to 0. However, after you install WMP 9, this 
text can reappear. To prevent this text from displaying on screen after you install WMP 9, perform 
the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates\CA\Certificates\ 
registry subkey. 
3. Delete the FEE449EE0E3965A5246F000E87FDE2A065FD89D4 subkey. 
4. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates\ROOT\Certificates registry 
subkey. 
5. Delete the 2BD63D28D7BCD0E251195AEB519243C13142EBC3 subkey. 
6. Close the registry editor. 
 
Q. How can I remove the Windows XP notification area (i.e., system tray) from the taskbar? 
 
A. To hide the notification area, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 
registry subkey to hide the notification area for the current user, or navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer 
registry subkey to hide the notification area for all users. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name NoTrayItemsDisplay, then press Enter. 
5. Double-click the new value, set it to 1, then click OK. 
6. Close the registry editor and log off or restart the machine for the change to take effect. 

BACK TO TOP 

 
Q. How can I stop Windows from caching a .dll file after I close the program that was 
accessing it? 
 
A. Windows caches .dll files to speed disk I/O. However, even after you close the calling program, 
the .dll file remains cached. To stop Windows from caching .dll files after you've closed the calling 
program, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer 
registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name AlwaysUnloadDLL, then press Enter. 
5. Double-click the new value, set it to 1, then click OK. 
6. Close the registry editor, then reboot the machine for the change to take effect. 
 
Q. How do I use the Windows XP alternative TCP/IP configuration? 
 
A. Laptop users often experience problems when moving between networks in which DHCP 
servers aren't consistently used (e.g., moving between an office that uses DHCP to assign IP 
addresses and a home network that uses static IP addresses). If you configure your computer to 
use DHCP and no DHCP server is available, the machine will typically use an IP address in the 



range 169.254.0.1 to 169.254.255.254 with a 
subnet mask of 255.255.0.0. The actual IP address will depend on what IP addresses other 
machines on the local subnet have selected (XP will perform a limited test to ensure the Windows 
TCP/IP component doesn't use an address already in use). Because the local TCP/IP stack 
assigns no WINS, DHCP, or gateway information, all IP communication is limited to machines in 
the local subnet. 
 
XP lets you create an alternative IP configuration that you can use when your system can't find a 
DHCP server. This alternative configuration lets you specify an IP address, subnet, gateway, and 
the other typical network settings. To create this alternative IP 
configuration, perform the following steps: 
1. Open the Control Panel Network Connections applet (go to Start, Programs, Accessories, 
Communications and click Network Connections). 
2. Right-click the network adapter for which you want to specify an alternate IP configuration, then 
click Properties. 
3. Select Internet Protocol (TCP/IP), then click Properties. 
4. Under the General tab, ensure that you've configured the connection to use DHCP. 
5. Select the Alternate Configuration tab, select "User configured", then fill in the static IP address 
details you want the connection to use when the system can't find a DHCP server. 
7. Click OK. 
8. Click OK again to close all remaining windows. 
 
XP stores the custom connection configuration settings under the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces 
registry subkey. 

Q. How can I change the Windows Messenger initial warning? 
 
A. When you start a new Windows Messenger session, the warning "Never give out your 
password or credit card number in an instant message conversation" appears in the top of the 
window by default. To modify this message text, perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MessengerService\Policies 
registry subkey. 
3. From the Edit menu, select New, String Value. 
4. Enter the name IMWarning, then press Enter. 
5. Double-click the new value, enter a new string of text that you want to appear in place of the 
warning message, then click OK. 
6. Close the registry editor. 
 
The change takes effect immediately. 
 
Q. How can I hide the Set Program Access and Defaults tool from all users of a particular 
machine? 
 
A. Windows XP Service Pack 1 (SP1) and Windows 2000 SP3 include a new GUI tool that lets 
you configure default program access for some OS components, including the Web browser, 
email client, Instant Messaging (IM) client, and media player. To hide this tool from all users, 
perform the following steps: 
1. Start a registry editor (e.g., regedit.exe). 
2. Navigate to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Uninstall 
registry subkey. 
3. From the Edit menu, select New, DWORD Value. 
4. Enter the name NoChooseProgramsPage, then press Enter. 



5. Double-click the new value, set it to 1, then click OK. 
6. Close the registry editor. 
7. Restart Windows for the change to take effect. 
 
You can configure the same setting for an individual user by changing the path in Step 2 to 
navigate to the 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall registry 
subkey. 
 
Q. How can I check a system's availability? 
 
A. Microsoft's Uptime tool, which you can download at 
http://www.microsoft.com/ntserver/nts/downloads/management/uptime/default.asp , 
displays basic system-uptime information. This tool can also list all startup and shutdown events, 
and you can use the /s switch to show the total percent time that your machine has been 
available. For example, when I type 
 
D:\temp>uptime /s 
 
on my machine, the Uptime tool displays the following information: 
 
Uptime Report for: \\EAGLE01 
 
Current OS: Microsoft Windows XP, Service Pack 1, Multiprocessor Free. Time Zone: GMT 
Standard Time 
 
System Events as of 07/11/2002 15:03:30: 
 
Date: Time: Event: Comment: 
---------- ------- ----------------- --------------------------- 
27/09/2002 10:54:46 Shutdown 
27/09/2002 10:56:42 Boot Prior downtime:0d 0h:1m:56s 
27/09/2002 13:21:54 Shutdown Prior uptime:0d 2h:25m:12s 
27/09/2002 13:23:36 Boot Prior downtime:0d 0h:1m:42s 
30/09/2002 08:46:37 Service Pack Service Pack 1 installed 
30/09/2002 08:47:50 Shutdown Prior uptime:2d 19h:24m:14s 
30/09/2002 08:52:57 Boot Prior downtime:0d 0h:5m:7s 
01/10/2002 08:45:22 Shutdown Prior uptime:0d 23h:52m:25s 
01/10/2002 08:50:30 Boot Prior downtime:0d 0h:5m:8s 
02/10/2002 10:46:07 Shutdown Prior uptime:1d 1h:55m:37s 
02/10/2002 10:48:38 Boot Prior downtime:0d 0h:2m:31s 
03/10/2002 08:52:48 Shutdown Prior uptime:0d 22h:4m:10s 
03/10/2002 08:58:31 Boot Prior downtime:0d 0h:5m:43s 
04/10/2002 15:56:58 Shutdown Prior uptime:1d 6h:58m:27s 
04/10/2002 16:02:47 Boot Prior downtime:0d 0h:5m:49s 
07/10/2002 13:23:54 Shutdown Prior uptime:2d 21h:21m:7s 
07/10/2002 13:25:46 Boot Prior downtime:0d 0h:1m:52s 
10/10/2002 14:55:03 Shutdown Prior uptime:3d 1h:29m:17s 
10/10/2002 15:01:13 Boot Prior downtime:0d 0h:6m:10s 
11/10/2002 09:19:20 Shutdown Prior uptime:0d 18h:18m:7s 
11/10/2002 09:21:08 Boot Prior downtime:0d 0h:1m:48s 
28/10/2002 09:24:07 Shutdown Prior uptime:17d 1h:2m:59s 
28/10/2002 09:26:48 Boot Prior downtime:0d 0h:2m:41s 
07/11/2002 08:22:25 Shutdown Prior uptime:9d 22h:55m:37s 
07/11/2002 08:24:18 Boot Prior downtime:0d 0h:1m:53s 
 



Current System Uptime: 0 day(s), 6 hour(s), 39 minute(s), 12 second(s) 
 
Estimate based on last boot record in the event log. See UPTIME /help for more detail. 

Since 27/09/2002: 
 
System Availability: 99.9287% 
Total Uptime: 41d 4h:26m:24s 
Total Downtime: 0d 0h:42m:20s 
Total Reboots: 12 
Mean Time Between Reboots: 3.43 days 
Total Bluescreens: 0 
 
Notice the final summary, which displays useful information such as the number of total reboots 
and the mean time between reboots. You can use the /d: switch to generate statistics from a 
certain date or use the /p: switch to generate the statistics for a certain number of days. The /help 
switch provides a description of all available options. 
 
Q. Why doesn't Windows 2000 Service Pack 3 (SP3) install the Set Program Access and 
Defaults tool when I apply the service pack to my Win2K server? 
 
A. The Set Program Access and Defaults tool is available only for Win2K Professional--the tool 
isn't available for any of the Win2K server versions. 
 
Q. Why can't I use a dial-up connection to access Web pages after I upgrade my system to 
Windows XP? 
 
A. You might experience a problem if you use Microsoft Internet Explorer (IE) and a dial-up 
connection to view Web pages if all of the following conditions are true: 
- You upgraded your system from Windows Me or Windows 98. 
- Before the upgrade, you configured on the computer a LAN connection that used a proxy 
server. 
- Before the upgrade, one or more of the dial-up connections didn't use a proxy server. 
 
If you meet all conditions, after you upgrade to XP, the OS installation software incorrectly copies 
the LAN proxy settings to the dial-up connections. To resolve this error, you must manually 
remove these settings from each dial-up connection by performing the following steps: 
1. Start IE. 
2. From the Tools menu, select Internet Options. 
3. Select the Connections tab. 
4. Select a dial-up networking entry, then click Settings. 
5. Clear the "Use a proxy server" check box. 
6. Repeat Steps 2 through 5 for each dial-up networking entry. 
7. Click OK to close the Internet Options dialog box. 
 
Q. Why can't I use My Computer to format a removable disk larger than 2GB as FAT in 
Windows XP? 
 
A. XP's My Computer interface lets you format a disk as FAT, FAT32, or NTFS. The maximum 
FAT partition size that you can create in XP is 4GB; however, a limitation in the My Computer 
interface prevents you from creating a FAT partition larger than 2GB. To work around this 
limitation, open a command prompt and type 
 
format <drive>: /fs:fat /v:<label> 
 
Q. What are the maximum volume sizes and maximum file sizes for the various Windows 



file systems? 
 
A. Windows 2000 and later support FAT, FAT32, and NTFS file systems. (The next version of 
Windows--code-named Longhorn--will support a new file system known as WinFS). The table at 
http://www.windows2000faq.com/articles/index.cfm?articleid=27253 lists the maximum volume 
sizes and maximum file sizes for FAT, FAT32, and NTFS. 

Q. Why can't I manually stop the Fax service in Windows 2000? 
 

A. Win2K's built-in FAX service doesn't run constantly. Instead, the service starts when an application 

requires the service. As a result, when you attempt to manually start and stop the service, you receive the 

following error: 

 

NET STOP FAX 

 

The Microsoft Fax Service service is not started. More help is available by typing NET HELPMSG 3521. 

 

Q. Why does the Magnifier utility start automatically whenever I boot my Windows 2000 or later 

machine? 
 

A. If you don't stop the Magnifier utility before you shut down your computer, Windows assumes that you 

want to use the utility the next time you start your computer and automatically runs it (the OS does this by 

adding the utility value to the 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce registry subkey). To 

stop the Magnifier utility, press Ctrl+Alt+Delete to open the Windows Task Manager, select the 

magnify.exe task from the Task tab, then click End Task. 

 

Q. Why do I receive the error message "Setup can not uninstall Windows XP because the necessary 

registration information is missing" when I try to uninstall XP? 
 

A. You might encounter this error message when you attempt to use the c:\windows\system32\osuninst.exe 

command and either of the following conditions exists on your computer:- The Undo folder isn't present on 

the system. 

- The Win9xundodirpath and Win9xundointegrityinfo registry values are not present in the 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup 

registry subkey. 

 

The Undo folder is typically at the root of the C drive and contains hidden and system attributes. To view 

the folder from the recovery console or command prompt, you need to type 

 

dir /ahs 

 

or set the folder permissions by typing 

 

attrib -sh c:\undo 

 

If the folder is missing, you can't uninstall the OS. 

 

If the registry information is missing, try restoring a previous registry backup. Again, if this information is 

missing, you won't be able to uninstall the OS. 

 

Q. What is Windows XP's Automatic Metric feature? 
 

A. XP introduced the TCP/IP Automatic Metric feature. The OS uses metrics to assign costs to IP routes 

that let the IP component select the "cheapest" cost route when sending packets. Traditionally, you could 

manually assign a cost to a route--XP lets you automatically assign a route cost according to the link's 



connection speed, as shown 

below: 

 

Link Speed Metric 

------------------------------------------------------------- ------- 

Greater than 200Mbps 10 

Greater than 20Mbps, and less than or equal to 200Mbps 20 

Greater than 4Mbps, and less than or equal to 20Mbps 30 

Greater than 500Kbps, and less than or equal to 4Mbps 40 

Less than or equal to 500Kbps 50 

 

Assigning route costs is useful when you have multiple network connections to one destination. In such a 

scenario, XP will use the fastest link connection because it will have the lowest cost. 

 

To see the end result, from the command prompt type 

 

route print 

 

The following sample shows metric values assigned for multiple IP routes: 

 

Active Routes: 

Network Destination Netmask Gateway Interface Metric 

0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.102 30 

0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.101 20 

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1 

192.168.1.0 255.255.255.0 192.168.1.101 192.168.1.101 20 

192.168.1.0 255.255.255.0 192.168.1.102 192.168.1.102 30 

192.168.1.101 255.255.255.255 127.0.0.1 127.0.0.1 20 

192.168.1.102 255.255.255.255 127.0.0.1 127.0.0.1 30 

192.168.1.255 255.255.255.255 192.168.1.101 192.168.1.101 20 

192.168.1.255 255.255.255.255 192.168.1.102 192.168.1.102 30 

224.0.0.0 240.0.0.0 192.168.1.101 192.168.1.101 20 

224.0.0.0 240.0.0.0 192.168.1.102 192.168.1.102 30 

255.255.255.255 255.255.255.255 192.168.1.101 192.168.1.101 1 

255.255.255.255 255.255.255.255 192.168.1.101 4 1 

255.255.255.255 255.255.255.255 192.168.1.102 192.168.1.102 1 

Default Gateway: 192.168.1.1 

 

In this sample, you can see two interfaces: 192.168.1.101 and 192.168.1.102. The first interface has a 

metric value of 20, and the second interface has a metric value of 30. The first interface, 192.168.1.101, is a 

100Mbps LAN link and the second interface, 

192.168.1.102, is an 11Mbps wireless network that connects to my 1Mbps broadband link. Where both 

interfaces are available, XP would use the lowest metric (i.e., 20), which corresponds to the 100Mbps link. 

 

Q. How can I disable Windows XP's Automatic Metric feature? 
 

A. To disable XP's Automatic Metric feature, perform the following steps: 

1. Open the Network Connections dialog box (go to Start, Settings, Control Panel, and select the Network 

Connections applet). 

2. Right-click the desired link, then select Properties. 

3. Select "Internet Protocol (TCP/IP)", then click Properties. 

4. Click the Advanced button. 

5. Clear "Automatic metric", then enter a metric value between 1 and 9999. 

6. Click OK to all dialog boxes. 

7. Ensure that the change has taken effect by typing 

 



route print 

 

at the command prompt 

 


